View unanswered posts | View active topics It is currently Mon Dec 10, 2018 12:13 am



Reply to topic  [ 3 posts ] 
 emissions 
Author Message

Post emissions
2003 GV 2.0 Petrol, passed last mot no problem, this year the emissions are through the roof. The car starts and runs fine, no engine management light. Swapped the map sensor, no difference, it even runs without it connected and still no engine management light. Wits end is looming----help me---please


Sat Mar 19, 2016 12:29 am

Offroad Guru
Offroad Guru

Joined: Fri Jan 18, 2008 9:52 pm
Posts: 1109
Karma: 3

Location: Brinkworth, Wiltshire
My Vehicle(s): Vitara / SJ / Jimny / Other
Post Re: emissions
What readings are you getting? The most likely culprits are the O2 sensor or the cat, assuming its properly serviced with the correct properly gapped spark plugs.


Sun Mar 27, 2016 7:53 pm
Profile WWW

Post Re: emissions
give it a good service.. and run and engine cleaner through it..


Thu Apr 28, 2016 6:15 pm
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Green Web Hosting! This site hosted by DreamHost.

phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by ST Software for PTF.
Karma functions powered by Karma MOD © 2007, 2009 m157y