Page 1 of 2

Vit no spark

Posted: Sat Apr 28, 2018 7:08 pm
by vitara s70
My 1.6 8v 4u2 Vitara is not getting a spark. Does anyone have any sugestions what it could be. It hasn't been started for around 3 years. Cheers Steve.

Re: Vit no spark

Posted: Wed May 02, 2018 7:16 am
by Sparks
I'd recommend a service. All the oils sat for 3 years, change the plugs, roots arm and dizzy cap.

Re: Vit no spark

Posted: Thu May 03, 2018 9:46 pm
by vitara s70
It seems the ecu is dead ~x(

Re: Vit no spark

Posted: Fri May 04, 2018 5:31 pm
by Munkee
I don't know if they're a straight swap, what with the key chip etc, but I may still have my old ecu...?

Re: Vit no spark

Posted: Sat May 05, 2018 1:45 pm
by jimny-dave
I swapped an ECU on the old Superzuki once after flooding it...

As long as it has the same part number on it, it should be ok...

Dave "still lurking" ;)

Re: Vit no spark

Posted: Sun May 06, 2018 12:13 pm
by Munkee
the later vits had a chipped key and immobiliser, I have no idea if it's a separate module to the ECU though?

Re: Vit no spark

Posted: Sun May 06, 2018 12:33 pm
by Munkee
IMG_0638.JPG

Re: Vit no spark

Posted: Mon May 07, 2018 11:17 am
by vitara s70
Cheers, I will have a look to see what the numbers are on mine. I think mine ha s a chip in the key.

Re: Vit no spark

Posted: Mon May 07, 2018 1:16 pm
by Munkee
It's from a Spanish 1999 1.6 8v 4U.

Re: Vit no spark

Posted: Mon May 07, 2018 6:51 pm
by vitara s70
I've not had chance to look yet but mine is a spanish 1999 4u2 8v 1.6
Would it need the key to match the ecu.

Re: Vit no spark

Posted: Mon May 07, 2018 9:09 pm
by Munkee
I don't know. The immobiliser module may be separate, but I really don't know.

Re: Vit no spark

Posted: Sun May 13, 2018 4:30 pm
by vitara s70
A big thankyou to Munkee for providing me with a replacement ecu. Sadly the Vit still doesn't want to start :-?? .

Re: Vit no spark

Posted: Tue May 15, 2018 1:33 am
by ubermeister
It's sulking because you left it on the drive for three years. Is it getting fuel?

Re: Vit no spark

Posted: Wed May 16, 2018 10:45 pm
by vitara s70
Its getting petrol but nothing to make it go bang. A match might help things along though %-(

Re: Vit no spark

Posted: Fri May 18, 2018 12:59 pm
by mud and diesel
If it’s getting fuel injected at the correct time then the ECU is fine, perhaps it’s the distributor, I’ve had one fail.