Page 2 of 2

Re: Vit no spark

Posted: Sat May 19, 2018 7:55 am
by vitara s70
There's no check engine light on the dashboard and according to Rhinomans page it means the ecu is dead.

Re: Vit no spark

Posted: Thu May 24, 2018 6:39 pm
by RadioRay
Have you checked that the main relay is feeding power to ecu and immobilizer, it's located under the dashboard between steering column and inner wing.

Re: Vit no spark

Posted: Fri May 25, 2018 7:24 pm
by vitara s70
Thanks, I will try that.

Re: Vit no spark

Posted: Sat Oct 26, 2019 2:17 pm
by vitara s70
Update. I've checked the relay and other connections and all are ok. After looking at the manuals on Rhinomans portal it seems as the ICM, ECM and key transponder are not communicating with each other. This happened 8 years ago and I had to tow it to the main dealer to get it recoded. I was thinking of buying the Tech2 diagnostic equipment as it will not be much more (I don't think). Has anyone used this tester before and does it connect to the terminals by the headlight?

Re: Vit no spark

Posted: Mon Nov 18, 2019 10:13 pm
by Sparks
Beyond my capabilities and knowledge :?

Re: Vit no spark

Posted: Wed Nov 20, 2019 11:00 pm
by vitara s70
Sparks wrote:
Mon Nov 18, 2019 10:13 pm
Beyond my capabilities and knowledge :?
probably mine too :))

Re: Vit no spark

Posted: Wed Mar 04, 2020 4:24 pm
by vitara s70
I got round to towing my Vit a round trip of 33 miles to and from the main stealers for them to say that the car is too old for their diagnostic check . The mechanic didn't even know where the terminal was, I had to tell him. I think my car was older than he was x_x We pushed it onto the ramp and I left him to it. Went to put it back on the A frame to tow it home, turned the key and it fired up :-? Could it be that because its been sitting for several years that the crank sensor had got stuck or dirty and towing it somehow moved it? :-\ At least there was no charge but I'm still none the wiser as to what was wrong with it.

Re: Vit no spark

Posted: Fri Mar 06, 2020 7:21 pm
by mud and diesel
That is crazy!!!

It’s either a loose connection or it thought you were trading it in for a new jimny and got its poo together :))

Re: Vit no spark

Posted: Sun Mar 08, 2020 7:30 pm
by vitara s70
So far so good, it's started first time every day since :-bd

Re: Vit no spark

Posted: Sun Mar 08, 2020 8:25 pm
by ubermeister
F-kn ripper. As soon as I sort my overheating issue, we'll all have to go for a drive somewhere.

Re: Vit no spark

Posted: Sat Mar 14, 2020 1:35 am
by Sparks
Mines currently under threat of been removed and crushed atm :roll:

So currently waiting for a friend hopefully tomorrow to trailer it to the new house so its safe from the council #:-s

Re: Vit no spark

Posted: Mon Mar 16, 2020 9:22 am
by vitara s70
Sparks wrote:
Sat Mar 14, 2020 1:35 am
Mines currently under threat of been removed and crushed atm :roll:

So currently waiting for a friend hopefully tomorrow to trailer it to the new house so its safe from the council #:-s
Did you get it moved?

Re: Vit no spark

Posted: Thu Mar 19, 2020 12:17 pm
by Sparks
Yep, safe on our driveway now, safe from the council and their crushing machine.

However not safe from the missus and wanting me to get rid of it :cry:

With the new baby I've lost most of my free time now. But i want to try and tinker with it again.